Error in step 4:design network

2 posts Page 1 of 1
mosman
Posts: 1
Joined: Wed Jan 30, 2019 10:30 pm


Hi.
Execute step 4 and print this error:
Algoritmo [step 4.0] Design network comenzando...
Creating graph...
Data preparation (initialization)...
Creating pricing points...

'demand' See log for more details

Logs
2019-01-30T19:22:27 2 Uncaught error while executing algorithm
Traceback (most recent call last):
File "/usr/share/qgis/python/plugins/processing/core/GeoAlgorithm.py", line 203, in execute
self.processAlgorithm(progress)
File "/home/providers/.qgis2/python/plugins/GniPlannerFTTH/design_network.py", line 187, in processAlgorithm
self.connectSplices(parentId, nodeId)
File "/home/providers/.qgis2/python/plugins/GniPlannerFTTH/design_network.py", line 310, in connectSplices
self.createPricingPoint(fromId)
File "/home/providers/.qgis2/python/plugins/GniPlannerFTTH/design_network.py", line 336, in createPricingPoint
splice.setAttribute(cf.P_DEMAND, feature.attribute(cf.NODE_DEMAND_FIELD_NAME))
KeyError: 'demand'
gni_support
Posts: 62
Joined: Wed Sep 20, 2017 1:05 pm


Hi,

The error says that one of layers has not attribute named 'demand',
so there was selected wrong layer in parameters.

You shoud check if parameters are set correctly.
If you need more help could you provide more information about planner version and selected parameters?
(screenshot with Layers Panel and algorithm parameters would be good)
2 posts Page 1 of 1
ekskluzywne stoły stoły włoskie nowoczesne