Unable to produce reports.

6 posts Page 1 of 1
Posts: 1
Joined: Fri Mar 12, 2021 1:35 pm

I have GNI working fine on widows 10 :D , all relevant modules loaded correctly including openpyxl etc. as per the instructions.

I can run through some modelling up to and including step 4, producing outputs as expected.

If I try to run a report I get a pop up dialog ... expected See log for more details ... and in the log the following detail: -

2021-03-12T14:26:48 2 Uncaught error while executing algorithm
Traceback (most recent call last):
File "C:/PROGRA~1/QGIS2~1.18/apps/qgis-ltr/./python/plugins\processing\core\GeoAlgorithm.py", line 203, in execute
File "C:/Users/XXXX/.qgis2/python/plugins\GniPlannerFTTH\planner_report.py", line 105, in processAlgorithm
File "C:/Users/XXXX/.qgis2/python/plugins\GniPlannerFTTH\planner_report.py", line 147, in fitColumnWidth
worksheet.column_dimensions[columnCells[0].column].width = max(length, 4)
File "C:\PROGRA~1\QGIS2~1.18\apps\Python27\lib\site-packages\openpyxl\utils\bound_dictionary.py", line 26, in __getitem__
setattr(value, self.reference, key)
File "C:\PROGRA~1\QGIS2~1.18\apps\Python27\lib\site-packages\openpyxl\descriptors\base.py", line 44, in __set__
raise TypeError('expected ' + str(self.expected_type))
TypeError: expected <type 'basestring'>

2021-03-12T14:26:48 1 There were errors executing the algorithm.

can you help or point me to some way to resolve please. Superb software, would be great if it ran on QGIS 3.. but for now well done.
Posts: 75
Joined: Wed Sep 20, 2017 1:05 pm

Which version of qgis are you using?
Posts: 2
Joined: Tue Sep 07, 2021 2:23 pm

I'm having the exact same problem.
I'm using QGIS 2.18.24.
Windows 10 x64.
openpyxl 2.6.4

Posts: 2
Joined: Tue Sep 07, 2021 2:23 pm

Downgraded openpyxl version and it worked!
Posts: 1
Joined: Wed Oct 20, 2021 11:51 am

Hi I use windows 10 x64.
Posts: 1
Joined: Wed May 18, 2022 12:22 am

as mentioned b4 i also solved it by downgrading openpyxl. to do that:
run the OSGeo4W shell (installed with QGis) as administrator then issue the command:
python -m pip install --upgrade openpyxl==2.5.4
6 posts Page 1 of 1
ekskluzywne stoły stoły włoskie nowoczesne