No module named openpyxl

8 posts Page 1 of 1
gni_support
Posts: 72
Joined: Wed Sep 20, 2017 1:05 pm


Cannot enable plugin GniPlannerFTTH, because occurs an error "No module named openpyxl".
Attachments
screen No module named openpyxl2.jpg
screen No module named openpyxl2.jpg (111.32 KiB) Viewed 11752 times
screen No module named openpyxl1.jpg
screen No module named openpyxl1.jpg (86.87 KiB) Viewed 11752 times
screen No module named openpyxl.png
screen No module named openpyxl.png (46.24 KiB) Viewed 11770 times
gni_support
Posts: 72
Joined: Wed Sep 20, 2017 1:05 pm


Solution Ubuntu:

Run this command in terminal:
sudo apt-get install python-openpyxl
or
pip install openpyxl

Solution Windows:

Install openpyxl python library (https://openpyxl.readthedocs.io/en/default/).
Locate "bin" folder in your QGIS installation folder (probably "C:\Program Files\QGIS 2.18\bin") and run these commands in windows command line as administrator:
python-qgis.bat -m pip install setuptools (if setuptools are not installed)
python-qgis.bat -m pip install openpyxl
Michael
Posts: 1
Joined: Mon Jan 01, 2018 8:18 pm


Hello

I have got a similar problem: First, there was the same situation as explained above ("No module named openpyxl").
I tryed to solve the ploblem by following the desciption above (for Windows).

Now I can not enable plugin GniPlannerFTTH, because occurs an error "cannot import name LXML ".

I am grateful for your help.
Attachments
003.png
003.png (22.97 KiB) Viewed 11100 times
002.png
002.png (53.88 KiB) Viewed 11100 times
001.png
001.png (57.97 KiB) Viewed 11100 times
gni_support
Posts: 72
Joined: Wed Sep 20, 2017 1:05 pm


Mon Jan 01, 2018 8:49 pmMichael wrote:

I have got a similar problem: First, there was the same situation as explained above ("No module named openpyxl").
I tryed to solve the ploblem by following the desciption above (for Windows).

Now I can not enable plugin GniPlannerFTTH, because occurs an error "cannot import name LXML ".
Hello,

Try running these commands:

python-qgis.bat -m pip install openpyxl
python-qgis.bat -m pip install lxml
akhil.chibber
Posts: 1
Joined: Mon Mar 26, 2018 11:54 am


Wed Sep 20, 2017 1:14 pmgni_support wrote:
Solution Ubuntu:

Run this command in terminal:
sudo apt-get install python-openpyxl
or
pip install openpyxl

Solution Windows:

Install openpyxl python library (https://openpyxl.readthedocs.io/en/default/).
Locate "bin" folder in your QGIS installation folder (probably "C:\Program Files\QGIS 2.18\bin") and run these commands in windows command line as administrator:
python-qgis.bat -m pip install setuptools (if setuptools are not installed)
python-qgis.bat -m pip install openpyxl




CAN YOU PLEASE ME OUT REGARDING WHERE WE HAVE TO TYPE THE COMMAND
python-qgis.bat -m pip install setuptools (if setuptools are not installed)
python-qgis.bat -m pip install openpyxl
???????????
BECAUSE CMD IS NOT ABLE TO READ THE ABOVE COMMAND
TheoA
Posts: 2
Joined: Fri Sep 21, 2018 12:36 pm


Hi,

I have installed the package using the instructions in the guide and have placed the python folder within the .qgis2 folder on the drive. However, when I try to download the report, I receive an error: Missing library - No module named openpyxl

Could you please let me know why does this error appear?

Thanks in advance,

T
jkowalsky
Posts: 1
Joined: Thu Oct 15, 2020 6:39 am


Hi,
I have the same problem. How to solve the problem it?
Thanks in advance.
gni_support
Posts: 72
Joined: Wed Sep 20, 2017 1:05 pm


Okay, so i've problably found solution to this problem...at least for windows version:
How to do it, step by step:

1.Open CMD and type: cd "(your location of qgis2.18 bin folder) ...example: cd "C:\Program Files\QGIS 2.18
2. Open your qgis2.18 bin folder, and look for python-qgis-(something).bat .... in my case it was python-qgis-ltr.bat
3. Now after you set your path into CMD type comands:

python-qgis-ltr.bat -m pip install setuptools (if setuptools are not installed) (Then press enter, it should run/install) .......after that type:

python-qgis-ltr.bat -m pip install openpyxl

4. Open qgis...

If it doesn't work, you probably didn't instal "pip" correctly
8 posts Page 1 of 1
ekskluzywne stoły stoły włoskie nowoczesne